Commit 3fa0d96c authored by Jan Trmal's avatar Jan Trmal
Browse files

(trunk) Check if the default python interpreter is 2.x

git-svn-id: https://svn.code.sf.net/p/kaldi/code/trunk@5122 5e6a8d80-dfce-4ca6-a32a-6e07a63d50c8
parent b347cf82
......@@ -37,6 +37,21 @@ if ! which awk >&/dev/null; then
add_packages gawk gawk
fi
if which python >&/dev/null ; then
version=`python 2>&1 --version | awk '{print $2}' `
if [[ $version != "2."* ]] ; then
if which python2.7 >&/dev/null || which python2 >&/dev/null ; then
echo "$0: python 2.7 is not the default python. You should either make it"
echo "$0: default or create an bash alias for kaldi scripts to run correctly"
else
echo "$0: python 2.7 is not installed"
add_packages python2.7 python2.7
fi
fi
else
echo "$0: python 2.7 is not installed"
add_packages python2.7 python2.7
fi
printed=false
status=0
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment