Commit 9d8225f6 authored by Florent Angebault's avatar Florent Angebault

git ignore bin/ dirs and other .gitignore files.

Fix otrs-3773 : 'Weird behavior of the "Compare with branch" feature'.

Issue subversive#484929: https://bugs.eclipse.org/bugs/show_bug.cgi?id=484929
Backported from 3.0.3 to 2.0.4.
parent 5175e8bb
**/bin/
.gitignore
<?xml version="1.0" encoding="UTF-8"?>
<feature
id="org.eclipse.team.svn"
label="%featureName"
version="2.0.4.I20150123-1700"
provider-name="%providerName"
plugin="org.eclipse.team.svn">
<install-handler/>
<description>
The Eclipse Team Provider for the Subversion version control system. For instructions about installing SVN connectors visit http://www.eclipse.org/subversive/downloads.php
</description>
<license url="license.html">
%license
</license>
<url>
<update label="%updateSiteName" url="http://download.eclipse.org/technology/subversive/2.0/update-site/"/>
<discovery label="%discoverySiteName" url="http://download.eclipse.org/technology/subversive/2.0/update-site/"/>
</url>
<requires>
<import plugin="org.eclipse.ui.intro"/>
<import plugin="org.eclipse.ui.intro.universal"/>
<import plugin="org.eclipse.ui"/>
<import plugin="org.eclipse.core.resources"/>
<import plugin="org.eclipse.core.runtime"/>
<import plugin="org.eclipse.team.core"/>
<import plugin="org.eclipse.core.filesystem"/>
<import plugin="org.eclipse.core.net" version="1.2.0" match="compatible"/>
<import plugin="org.eclipse.equinox.security" version="1.0.0" match="compatible"/>
<import plugin="com.ibm.icu"/>
<import plugin="org.eclipse.ui.ide"/>
<import plugin="org.eclipse.ui.views"/>
<import plugin="org.eclipse.jface.text"/>
<import plugin="org.eclipse.ui.workbench.texteditor"/>
<import plugin="org.eclipse.ui.editors"/>
<import plugin="org.eclipse.team.ui"/>
<import plugin="org.eclipse.compare"/>
<import plugin="org.eclipse.osgi"/>
<import plugin="org.eclipse.help"/>
<import plugin="org.eclipse.ui.console"/>
<import plugin="org.eclipse.ui.navigator"/>
<import plugin="org.eclipse.ui.forms"/>
<import plugin="org.eclipse.ui.browser"/>
</requires>
<plugin
id="org.eclipse.team.svn"
download-size="4"
install-size="4"
version="2.0.4.I20150123-1700"
unpack="false"/>
<plugin
id="org.eclipse.team.svn.core"
download-size="900"
install-size="900"
version="2.0.4.I20150123-1700"
unpack="false"/>
<plugin
id="org.eclipse.team.svn.ui"
download-size="1600"
install-size="1600"
version="2.0.3.I20141224-1700"
unpack="false"/>
<plugin
id="org.eclipse.team.svn.ui.startup"
download-size="1600"
install-size="1600"
version="2.0.3.I20141224-1700"
unpack="false"/>
<plugin
id="org.eclipse.team.svn.help"
download-size="1900"
install-size="1900"
version="2.0.4.I20150123-1700"
unpack="false"/>
</feature>
<?xml version="1.0" encoding="UTF-8"?>
<feature
id="org.eclipse.team.svn"
label="%featureName"
version="2.0.4.I20160106-1700-linagora"
provider-name="%providerName"
plugin="org.eclipse.team.svn">
<install-handler/>
<description>
The Eclipse Team Provider for the Subversion version control system. For instructions about installing SVN connectors visit http://www.eclipse.org/subversive/downloads.php
</description>
<license url="license.html">
%license
</license>
<url>
<update label="%updateSiteName" url="http://download.eclipse.org/technology/subversive/2.0/update-site/"/>
<discovery label="%discoverySiteName" url="http://download.eclipse.org/technology/subversive/2.0/update-site/"/>
</url>
<requires>
<import plugin="org.eclipse.ui.intro"/>
<import plugin="org.eclipse.ui.intro.universal"/>
<import plugin="org.eclipse.ui"/>
<import plugin="org.eclipse.core.resources"/>
<import plugin="org.eclipse.core.runtime"/>
<import plugin="org.eclipse.team.core"/>
<import plugin="org.eclipse.core.filesystem"/>
<import plugin="org.eclipse.core.net" version="1.2.0" match="compatible"/>
<import plugin="org.eclipse.equinox.security" version="1.0.0" match="compatible"/>
<import plugin="com.ibm.icu"/>
<import plugin="org.eclipse.ui.ide"/>
<import plugin="org.eclipse.ui.views"/>
<import plugin="org.eclipse.jface.text"/>
<import plugin="org.eclipse.ui.workbench.texteditor"/>
<import plugin="org.eclipse.ui.editors"/>
<import plugin="org.eclipse.team.ui"/>
<import plugin="org.eclipse.compare"/>
<import plugin="org.eclipse.osgi"/>
<import plugin="org.eclipse.help"/>
<import plugin="org.eclipse.ui.console"/>
<import plugin="org.eclipse.ui.navigator"/>
<import plugin="org.eclipse.ui.forms"/>
<import plugin="org.eclipse.ui.browser"/>
</requires>
<plugin
id="org.eclipse.team.svn"
download-size="4"
install-size="4"
version="2.0.4.I20160106-1700-linagora"
unpack="false"/>
<plugin
id="org.eclipse.team.svn.core"
download-size="900"
install-size="900"
version="2.0.4.I20160106-1700-linagora"
unpack="false"/>
<plugin
id="org.eclipse.team.svn.ui"
download-size="1600"
install-size="1600"
version="2.0.3.I20160106-1700-linagora"
unpack="false"/>
<plugin
id="org.eclipse.team.svn.ui.startup"
download-size="1600"
install-size="1600"
version="2.0.3.I20141224-1700"
unpack="false"/>
<plugin
id="org.eclipse.team.svn.help"
download-size="1900"
install-size="1900"
version="2.0.4.I20150123-1700"
unpack="false"/>
</feature>
......@@ -2,7 +2,7 @@
<feature
id="org.eclipse.team.svn.core"
label="%featureName"
version="2.0.4.I20150123-1700"
version="2.0.4.I20160106-1700-linagora"
provider-name="%providerName"
plugin="org.eclipse.team.svn.core">
<install-handler/>
......@@ -34,7 +34,7 @@
id="org.eclipse.team.svn.core"
download-size="900"
install-size="900"
version="2.0.4.I20150123-1700"
version="2.0.4.I20160106-1700-linagora"
unpack="false"/>
<plugin
......
......@@ -3,7 +3,7 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5, JavaSE-1.6
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.team.svn.core;singleton:=true
Bundle-Version: 2.0.4.I20150123-1700
Bundle-Version: 2.0.4.I20160106-1700-linagora
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.team.svn.core.SVNTeamPlugin
Bundle-Vendor: %providerName
......
......@@ -1358,7 +1358,7 @@ public class SVNRemoteStorage extends AbstractSVNStorage implements IRemoteStora
return status;
}
protected static String getTextStatusString(int propKind, int textKind, boolean isRemoteStatus) {
public static String getTextStatusString(int propKind, int textKind, boolean isRemoteStatus) {
String status = IStateFilter.ST_NORMAL;
switch (textKind) {
case org.eclipse.team.svn.core.connector.SVNEntryStatus.Kind.IGNORED: {
......
......@@ -3,7 +3,7 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5, JavaSE-1.6
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.team.svn.ui;singleton:=true
Bundle-Version: 2.0.3.I20141224-1700
Bundle-Version: 2.0.3.I20160106-1700-linagora
Bundle-ClassPath: .
Bundle-Activator: org.eclipse.team.svn.ui.SVNTeamUIPlugin
Bundle-Vendor: %providerName
......
......@@ -3,7 +3,7 @@ Bundle-RequiredExecutionEnvironment: J2SE-1.5, JavaSE-1.6
Bundle-ManifestVersion: 2
Bundle-Name: %pluginName
Bundle-SymbolicName: org.eclipse.team.svn;singleton:=true
Bundle-Version: 2.0.4.I20150123-1700
Bundle-Version: 2.0.4.I20160106-1700-linagora
Bundle-Vendor: %providerName
Bundle-Localization: plugin
Require-Bundle: org.eclipse.ui.intro,
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment